use strict;
my $str = '/qualquer-coisa/index.php
/qualquer-coisa1/index.php
/qualquer-coisa2/index.php
/qualquer-coisa3/index.php
/qualquer-coisa4/index.php
/qualquer-coisa5/index.php
/qualquer-coisa6/
/qualquer-coisa7';
my $regex = qr/^\/?[^\/]*(\/(.*))?$/mp;
my $subst = '/pasta_do_site/$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";