package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/?[^\/]*(\/(.*))?$`)
var str = `/qualquer-coisa/index.php
/qualquer-coisa1/index.php
/qualquer-coisa2/index.php
/qualquer-coisa3/index.php
/qualquer-coisa4/index.php
/qualquer-coisa5/index.php
/qualquer-coisa6/
/qualquer-coisa7`
var substitution = "/pasta_do_site/$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}