# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*?)(?:\s+v[0-9]+|\s+vol\.?\s*[0-9]+)/$1/gi;t' <<< "This is what I want v1
This is what I want Vol.27
This is what I want vol 1
This is what I want VOL. 27
"