using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)(?:\s+v[0-9]+|\s+vol\.?\s*[0-9]+)";
string substitution = @"$1";
string input = @"This is what I want v1
This is what I want Vol.27
This is what I want vol 1
This is what I want VOL. 27
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}