const regex = /(.*?)(?:\s+v[0-9]+|\s+vol\.?\s*[0-9]+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)(?:\\s+v[0-9]+|\\s+vol\\.?\\s*[0-9]+)', 'gi')
const str = `This is what I want v1
This is what I want Vol.27
This is what I want vol 1
This is what I want VOL. 27
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);