$re = '/(.*?)(?:\s+v[0-9]+|\s+vol\.?\s*[0-9]+)/i';
$str = 'This is what I want v1
This is what I want Vol.27
This is what I want vol 1
This is what I want VOL. 27
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;