# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*?)(?:\s+v[0-9]+|\s+vol\.?\s*[0-9]+)"
test_str = ("This is what I want v1\n"
"This is what I want Vol.27\n"
"This is what I want vol 1\n"
"This is what I want VOL. 27\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.