// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(.*?)(?:\s+v[0-9]+|\s+vol\.?\s*[0-9]+)").unwrap();
let string = "This is what I want v1
This is what I want Vol.27
This is what I want vol 1
This is what I want VOL. 27
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}