#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(.*?)(?:\s+v[0-9]+|\s+vol\.?\s*[0-9]+)"
Local $sString = "This is what I want v1" & @CRLF & _
"This is what I want Vol.27" & @CRLF & _
"This is what I want vol 1" & @CRLF & _
"This is what I want VOL. 27" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)