use strict;
my $str = 'This is what I want v1
This is what I want Vol.27
This is what I want vol 1
This is what I want VOL. 27
';
my $regex = qr/(.*?)(?:\s+v[0-9]+|\s+vol\.?\s*[0-9]+)/ip;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";