package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(.*?)(?:\s+v[0-9]+|\s+vol\.?\s*[0-9]+)`)
var str = `This is what I want v1
This is what I want Vol.27
This is what I want vol 1
This is what I want VOL. 27
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}