#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^>]+>$"
Local $sString = "Str$#$ing1>Stri$#$ng2>String3>Stri#$$#ng4>St#$#$ring5>" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)