import re
regex = re.compile(r"[^>]+>$")
test_str = ("Str$#$ing1>Stri$#$ng2>String3>Stri#$$#ng4>St#$#$ring5>\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)