$re = '/[^>]+>$/';
$str = 'Str$#$ing1>Stri$#$ng2>String3>Stri#$$#ng4>St#$#$ring5>
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;