// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^>]+>$").unwrap();
let string = "Str$#$ing1>Stri$#$ng2>String3>Stri#$$#ng4>St#$#$ring5>
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}