const regex = /[^>]+>$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^>]+>$', 'g')
const str = `Str\$#\$ing1>Stri\$#\$ng2>String3>Stri#\$\$#ng4>St#\$#\$ring5>
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);