re = /[^>]+>$/
str = 'Str$#$ing1>Stri$#$ng2>String3>Stri#$$#ng4>St#$#$ring5>
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result