using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^>]+>$";
string substitution = @"";
string input = @"Str$#$ing1>Stri$#$ng2>String3>Stri#$$#ng4>St#$#$ring5>
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}