using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\s+(?:[^>]*?\s+)?href=[""']([^""']*)['""]";
string input = @"sdjhfjksdf
a=b sf sf sdf sf sdf http://sdjhfjksdf
http://sdjhfjksdf.com/
https://sdjhfjksdf.com.ru
<a href=""dfgdf dfg dfgya.ru"">
<a href='https://sdjhfjksdf.com.ru/mad?a=b&c=d_dj#uadfd'>test</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}