const regex = /<a\s+(?:[^>]*?\s+)?href=["']([^"']*)['"]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a\\s+(?:[^>]*?\\s+)?href=["\']([^"\']*)[\'"]', 'gm')
const str = `sdjhfjksdf
a=b sf sf sdf sf sdf http://sdjhfjksdf
http://sdjhfjksdf.com/
https://sdjhfjksdf.com.ru
<a href="dfgdf dfg dfgya.ru">
<a href='https://sdjhfjksdf.com.ru/mad?a=b&c=d_dj#uadfd'>test</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}