import re
regex = re.compile(r"<a\s+(?:[^>]*?\s+)?href=[\"']([^\"']*)['\"]", flags=re.MULTILINE)
test_str = ("sdjhfjksdf\n"
"a=b sf sf sdf sf sdf http://sdjhfjksdf\n"
"http://sdjhfjksdf.com/\n"
"https://sdjhfjksdf.com.ru\n"
" <a href=\"dfgdf dfg dfgya.ru\">\n"
"<a href='https://sdjhfjksdf.com.ru/mad?a=b&c=d_dj#uadfd'>test</a>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")