import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s+(?:[^>]*?\\s+)?href=[\"']([^\"']*)['\"]";
final String string = "sdjhfjksdf\n"
+ "a=b sf sf sdf sf sdf http://sdjhfjksdf\n"
+ "http://sdjhfjksdf.com/\n"
+ "https://sdjhfjksdf.com.ru\n"
+ " <a href=\"dfgdf dfg dfgya.ru\">\n"
+ "<a href='https://sdjhfjksdf.com.ru/mad?a=b&c=d_dj#uadfd'>test</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}