// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a\s+(?:[^>]*?\s+)?href=["']([^"']*)['"]"#).unwrap();
let string = "sdjhfjksdf
a=b sf sf sdf sf sdf http://sdjhfjksdf
http://sdjhfjksdf.com/
https://sdjhfjksdf.com.ru
<a href=\"dfgdf dfg dfgya.ru\">
<a href='https://sdjhfjksdf.com.ru/mad?a=b&c=d_dj#uadfd'>test</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}