$re = '/<a\s+(?:[^>]*?\s+)?href=["\']([^"\']*)[\'"]/m';
$str = 'sdjhfjksdf
a=b sf sf sdf sf sdf http://sdjhfjksdf
http://sdjhfjksdf.com/
https://sdjhfjksdf.com.ru
<a href="dfgdf dfg dfgya.ru">
<a href=\'https://sdjhfjksdf.com.ru/mad?a=b&c=d_dj#uadfd\'>test</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);