re = /<a\s+(?:[^>]*?\s+)?href=["']([^"']*)['"]/m
str = 'sdjhfjksdf
a=b sf sf sdf sf sdf http://sdjhfjksdf
http://sdjhfjksdf.com/
https://sdjhfjksdf.com.ru
<a href="dfgdf dfg dfgya.ru">
<a href=\'https://sdjhfjksdf.com.ru/mad?a=b&c=d_dj#uadfd\'>test</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end