# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<img(.*?)\\/(.*?)\\/(.*?)\.gif">/:$3:/gm;t' <<< "<img style=\"cursor:pointer;\" onclick=\"S("lightfly")\" src=\"chat/smiles/smiles_lightfly.gif\"> <img style=\"cursor:pointer;\" onclick=\"S("laugh")\" src=\"chat/smiles/smiles_laugh.gif\">"