const regex = /<img(.*?)\/(.*?)\/(.*?)\.gif">/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img(.*?)\\\/(.*?)\\\/(.*?)\\.gif">', 'gm')
const str = `<img style="cursor:pointer;" onclick="S("lightfly")" src="chat/smiles/smiles_lightfly.gif"> <img style="cursor:pointer;" onclick="S("laugh")" src="chat/smiles/smiles_laugh.gif">`;
const subst = `:$3:`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);