use strict;
my $str = '<img style="cursor:pointer;" onclick="S("lightfly")" src="chat/smiles/smiles_lightfly.gif"> <img style="cursor:pointer;" onclick="S("laugh")" src="chat/smiles/smiles_laugh.gif">';
my $regex = qr/<img(.*?)\/(.*?)\/(.*?)\.gif">/mp;
my $subst = ':$3:';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";