import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img(.*?)\\/(.*?)\\/(.*?)\\.gif\">";
final String string = "<img style=\"cursor:pointer;\" onclick=\"S("lightfly")\" src=\"chat/smiles/smiles_lightfly.gif\"> <img style=\"cursor:pointer;\" onclick=\"S("laugh")\" src=\"chat/smiles/smiles_laugh.gif\">";
final String subst = ":$3:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}