import Foundation
let pattern = #"<img(.*?)\/(.*?)\/(.*?)\.gif">"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<img style="cursor:pointer;" onclick="S("lightfly")" src="chat/smiles/smiles_lightfly.gif"> <img style="cursor:pointer;" onclick="S("laugh")" src="chat/smiles/smiles_laugh.gif">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #":$3:"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)