// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<img(.*?)\/(.*?)\/(.*?)\.gif">"#).unwrap();
let string = "<img style=\"cursor:pointer;\" onclick=\"S("lightfly")\" src=\"chat/smiles/smiles_lightfly.gif\"> <img style=\"cursor:pointer;\" onclick=\"S("laugh")\" src=\"chat/smiles/smiles_laugh.gif\">";
let substitution = ":$3:";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}