package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<img(.*?)\/(.*?)\/(.*?)\.gif">`)
var str = `<img style="cursor:pointer;" onclick="S("lightfly")" src="chat/smiles/smiles_lightfly.gif"> <img style="cursor:pointer;" onclick="S("laugh")" src="chat/smiles/smiles_laugh.gif">`
var substitution = ":$3:"
fmt.Println(re.ReplaceAllString(str, substitution))
}