$re = '/<img(.*?)\/(.*?)\/(.*?)\.gif">/m';
$str = '<img style="cursor:pointer;" onclick="S("lightfly")" src="chat/smiles/smiles_lightfly.gif"> <img style="cursor:pointer;" onclick="S("laugh")" src="chat/smiles/smiles_laugh.gif">';
$subst = ":$3:";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;