re = /<img(.*?)\/(.*?)\/(.*?)\.gif">/m
str = '<img style="cursor:pointer;" onclick="S("lightfly")" src="chat/smiles/smiles_lightfly.gif"> <img style="cursor:pointer;" onclick="S("laugh")" src="chat/smiles/smiles_laugh.gif">'
subst = ':$3:'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result