using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img(.*?)\/(.*?)\/(.*?)\.gif"">";
string substitution = @":$3:";
string input = @"<img style=""cursor:pointer;"" onclick=""S("lightfly")"" src=""chat/smiles/smiles_lightfly.gif""> <img style=""cursor:pointer;"" onclick=""S("laugh")"" src=""chat/smiles/smiles_laugh.gif"">";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}