#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(app)(\d+)"
Local $sString = "app1" & @CRLF & _
"app2"
Local $sSubst = "proxy_pass http://127.0.0.1:808$2/$1$2;"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)