package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(app)(\d+)`)
var str = `app1
app2`
var substitution = "proxy_pass http://127.0.0.1:808$2/$1$2;"
fmt.Println(re.ReplaceAllString(str, substitution))
}