import re
regex = re.compile(r"(app)(\d+)")
test_str = ("app1\n"
"app2")
subst = "proxy_pass http://127.0.0.1:808$2/$1$2;"
result = regex.sub(subst, test_str)
if result:
print(result)