$re = '/(app)(\d+)/';
$str = 'app1
app2';
$subst = "proxy_pass http://127.0.0.1:808$2/$1$2;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;