using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(app)(\d+)";
string substitution = @"proxy_pass http://127.0.0.1:808$2/$1$2;";
string input = @"app1
app2";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}