const regex = /(app)(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(app)(\\d+)', 'g')
const str = `app1
app2`;
const subst = `proxy_pass http://127.0.0.1:808$2/$1$2;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);