// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(app)(\d+)").unwrap();
let string = "app1
app2";
let substitution = "proxy_pass http://127.0.0.1:808$2/$1$2;";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}