re = /(app)(\d+)/
str = 'app1
app2'
subst = 'proxy_pass http://127.0.0.1:808$2/$1$2;'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result