# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"id":\s*"\K[^"]*/replaced/gm;t' <<< " \"id\": \"EFM\",
\"type\": \"Casual\",
\"hasBeenAssigned\": false,
\"hasRandomAssigned\": false
},"