$re = '/"id":\s*"\K[^"]*/m';
$str = ' "id": "EFM",
"type": "Casual",
"hasBeenAssigned": false,
"hasRandomAssigned": false
},';
$subst = "replaced";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;