import Foundation
let pattern = #""id":\s*"\K[^"]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"id": "EFM",
"type": "Casual",
"hasBeenAssigned": false,
"hasRandomAssigned": false
},
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"replaced"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)