use strict;
my $str = ' "id": "EFM",
"type": "Casual",
"hasBeenAssigned": false,
"hasRandomAssigned": false
},';
my $regex = qr/"id":\s*"\K[^"]*/mp;
my $subst = 'replaced';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";