import re
regex = re.compile(r"\"id\":\s*\"\K[^\"]*", flags=re.MULTILINE)
test_str = (" \"id\": \"EFM\",\n"
" \"type\": \"Casual\",\n"
" \"hasBeenAssigned\": false,\n"
" \"hasRandomAssigned\": false\n"
" },")
subst = "replaced"
result = regex.sub(subst, test_str)
if result:
print(result)