import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"id\":\\s*\"\\K[^\"]*";
final String string = " \"id\": \"EFM\",\n"
+ " \"type\": \"Casual\",\n"
+ " \"hasBeenAssigned\": false,\n"
+ " \"hasRandomAssigned\": false\n"
+ " },";
final String subst = "replaced";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}