const regex = /"id":\s*"\K[^"]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"id":\\s*"\\K[^"]*', 'gm')
const str = ` "id": "EFM",
"type": "Casual",
"hasBeenAssigned": false,
"hasRandomAssigned": false
},`;
const subst = `replaced`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);